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Tutorial 1d     : 2D Mesh Generation with  
«     Badge for 2D Meshing     »  

1. Introduction  

The objective of this tutorial is :
- to generate a 2D mesh around a circular cylinder.

The considered 3D geometry is shown below.

Cylinder geometry

After this tutorial, you will be able to :
- create a computation domain from simple geometries 
- generate a 2D mesh
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2. Creating the computation domain and generating the mesh  

2.1 Starting a new simulation

To start Star CCM+ (with Linux), write the two following commands in the terminal:
module load starccm/16.02
starccm

When Star CCM+ is opened, start a new simulation :
In the main menu bar, File -> New ...
Start a parallel session with 8 cores to accelerate the simulation
Process options = Serial
Click « OK »

Contrary to the previous tutorials we selected « Serial » for « Process options » because we only
generate a mesh in that tutorial, whereas we ran the simulations for the previous tutorials.

2.2 Creating a 3D Computation Domain

The computation domain will be created from the subtraction of a cylinder to a block.
For the 2D mesh generation, we will use the « Badge for 2D Meshing ».
This tool will create a 2D mesh from the face that lies in the plane Z=0 on a 3D geometry.

We need to create a 3D geometry first. We create a block whose side face lies in the plane Z=0 :
Go into « Geometry » -> right click on « Parts » -> New Shape Part -> Block
Define the Maximum and Minimum Coordinates :
Corner 1 : X = -1.0m ; Y = -1.0m ; Z = 0.0m
Corner 2 : X = 1.0m ; Y = 1.0m ; Z = 0.2m
Click « Create » then « Close »

« Block » was created in Parts. If we go to « Parts » -> Block -> Surfaces, there is only one surface
named  « Block  Surface ».  However  we  need  several  surfaces  to  define  the  different  boundary
conditions (inlet, outlet ...).
To split the surface :
Select « Block Surface » then right click -> Split by Angle
In the window « Split Part Surfaces by Angle » :
Verify « Block Surface » is chosen
Define an angle of 89.0 degrees
Click « OK »
Since « Block surface » was splitted where the angle is above 89 degrees, we have now 6 surfaces
named « Block Surface » followed by a number.

To display the geometry and the different boundaries, we need to create a geometry scene :
In the tree, right click on « Scenes » -> New Scene -> Geometry

We rename these 6 surfaces as shown on the figure below. To rename a surface :
Select the surface and right click -> Rename, and rename the surface with the name given on the
figure below.
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Names for the 6 block surfaces

Note the surface « Left » lies on the plane z=0 ! This surface will be used further to define the
2D mesh.

We create now the cylinder :
Still into « Geometry » -> right click on « Parts » -> New Shape Part -> cylinder
Define the axis position and the radius :
Start coordinate : X = 0.0m ; Y = 0.0m ; Z = -0.01m
End coordinate : X = 0.0m ; Y = 0.0m ; Z = 0.21m
Radius = 0.05m
Click « Create » then « Close »

Note that the Z coordinates were defined to extrude the cylinder outside from the block for both
sides (Z=0.0 and 0.2m for the block). The reason is we could have subtraction issue if they were
equal.

The block is now ready for the subtraction with the cylinder :
Go to « Geometry » -> right click on « Operations » -> New -> Boolean ->  Subtract
In the « Create Subtract Operation » window :
Input Parts = Block & Cylinder
Target Part = Block (the cylinder will be subtracted to the block)
Click « OK »

As a result of the previous operation, we obtain :
- a part named « Subtract » was created in « Parts » ;
- an operation named « Subtract » was created in « Operations ».
We need to execute that subtraction :
Right click on « Subract » (in Operations) -> Execute
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If we have a look inside the part « Subtract », we have all the surfaces and curves defined before.
We can rename this « Subtract » part :
Right click on « Subtract » (in Geometry) -> Rename, rename the part « Domain »

2.3 Converting the 3D Domain into 2D Domain

We want now to convert the 3D domain into 2D domain.
Go to « Geometry » -> right click on « Operations » -> New -> Mesh -> Badge for 2D Meshing
In the « Create Badge for 2D Meshing Operation » window :
Parts = Domain
Click « OK »

A « Badge for 2D Meshing » operation was created in « Operations »
We execute that operation :
Right click on « Badge for 2D Meshing » -> Execute

The part «     Domain     » was converted into 2D.  
We have now a computation domain whose shape corresponds to the surface of the 3D geometry
lying on plane Z=0.

2.4 Assigning Domain to a region

We have now the geometry for the computation domain. We just need to assign this geometry to a
region.
Select « Domain » (in Geometry -> Parts) and right click -> Assign Parts to Regions ...
Verify that only « Domain » is chosen in « Parts »
Choose « Create a Boundary for Each Part Surface » (and not « Create a Boundary for Each Part »)
Click « Apply » then « Close »

This last option is very important. If you chose « Create a Boundary for Each Part », there would be
only one boundary condition for the whole computation domain. It would not be possible to define
separately an inlet, an outlet and walls.

If you  go to « Regions », you can see a « Region » was created after the last operation « Assign
Parts to Regions ». Inside this Region, there are several boundaries with the names defined before.
If you have only one Boundary, that means you chose « Create a Boundary for Each Part » instead
of « Create a Boundary for Each Part Surface » for the previous operation. In that case, you can
delete your region and do again the last operation with the correct option.

2.5 Defining the Meshing Parameters

We need to define the Meshing Operations with different mesh models and parameters to mesh the
Region. To create an automated mesh operation :
Go to « Geometry » -> right click on « Operations » -> New -> Mesh -> Automated Mesh (2D)
In the « Create Automated Mesh Operation » window :
Parts = Domain
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The different Surface and Volume Meshers were already described in tutorials 1a & 1b.
We chose the Polygonal Mesher with Prism Layer Mesher :
Go to « Geometry » -> Operations -> Automated Mesh (2D) -> double click on « Meshers »
In the « Select Meshers » window, select « Polugonal Mesher », then « Prism Layer Mesher »

We need to define default values for the mesh. These values will be set for the whole computation
domain.
There are two ways to define each mesh size in Star CCM+ :
- « Relative to Base », the size is defined with a « Pourcentage of Base » relative to a « Base Size »
- « Absolute », the size is defined with an absolute size, and does not depend on the « Base Size »

Go to « Geometry » -> Operations -> Automated Mesh (2D) -> Default Controls

These default values were already described in tutorials 1a & 1b.
For our case, we set the following parameters (press « Enter » on your keyboard after every value
change) :
Base Size = 1.0m
Target Surface Size

-> Size Type = Relative to Base
-> Percentage of Base = 0.25 %

Minimum Surface Size
-> Size Type = Relative to Base
-> Percentage of Base = 0.125 %

Surface Curvature -> # Pts/circle = 36
Surface Growth Rate

-> Surface Growth Rate = User Specified
-> User Specified Value = 1.1

Number of Prism Layers = 18
Prism Layer Stretching = 1.25
Prism Layer Thickness 

-> Size Type = Absolute
-> Absolute Size = 0.01 m

All default values are now defined. They will be used for the whole computation domain. However
all sizes for the surface mesh were chosen for the cylinder surface, and we need different sizes for
the other surfaces (Inlet, Outlet, Top, Bottom).
We define other Target and Minimum Surface Sizes for these surfaces :
Go to « Geometry » -> Operations -> Automated Mesh (2D) -> Right click on « Custom Controls »
-> New -> Surface Control
A Surface Control was created. We rename that Surface Control :
Right click on « Surface Control » -> Rename, and rename the surface control « Far-field »

We select now the surfaces for which we want different surface mesh sizes :
Go on « Far-field », and in the « Properties » window -> Part Surfaces
In the « Far-Field - Part Surfaces » window,

-> Domain -> Block, select all surfaces except «     Left     »   (because the latter is the computation
domain without the boundaries)

We can see in « Controls » (below Far-field) it is possible, for the surfaces we selected, to define



Tutorial 1d : 2D Mesh Generation with « Badge for 2D Meshing »

other values for the parameters we set before in « Default Controls ».
All those parameters in « Controls » are set to « Parent » by default. That means they will use the
values defined previously in « Default Controls ».

We change the Target and Minimum Surface Sizes :
In « Far-field » -> Controls -> Target Surface size

-> Target Size Surface = Custom
Still in « Far-field » -> Controls -> Minimum Surface size

-> Minimum Size Surface = Custom

« Values »  appeared  below  « Controls ». We  can  define  minimum  and  target  sizes  for  the
boundaries  selected  in  « Far-field ».  Since  they  are  far-field  conditions,  we define  larger  mesh
sizes :
In « Far-field » -> Values -> Target Surface Size

-> Size Type = Relative to Base
-> Percentage of Base = 10 %

Still in « Far-field » -> Values -> Minimum Surface Size
-> Size Type = Relative to Base
-> Percentage of Base = 0.125 %

Since the far-field boundaries are flat surfaces without constrain imposing a mesh refinement, the
relative target surface size of 10 % will be used for the whole set of surfaces.

For these 4 surfaces, we do not want prism layers, because they are far-field conditions (and not
walls). We disable the generation of prism layers :
Still in « Far-field » -> Controls -> Prism Layers, in « Properties » window change Prism Layers to
« Disable »

We refine now the mesh in the wake :
Go to « Geometry » -> Operations -> Automated Mesh (2D) -> Right click on « Custom Controls »
-> New -> Surface Control
A Surface Control was created. We rename that Surface Control :
Right click on « Surface Control » -> Rename, and rename the surface control « Wake »

We define the mesh refinement in the wake :
Go to « Wake », in the « Wake - Properties » window :

Parts = Domain -> Cylinder -> Cylinder Surface (the mesh refinement starts from the
cylinder surface)

Go on « Wake » -> Controls -> Wake Refinement, activate « Specify Wake Refinement Options » in
the « Wake Refinement - Properties » window
Still  in  « Wake »,  go  to  « Values »  -> Wake Refinement,  in  « Wake Refinement  -  Properties »
window :

Size Type = Relative to Base
Distance = 0.3m (distance for mesh refinement downstream the cylinder)
Coordinate System = Laboratory
Direction = [1.0, 0.0, 0.0] (mesh refinement along X-axis direction)

Below « Wake Refinement » :
Isotropic Size : Percentage of Base = 0.25 %
Wake Refinement : Growth Rate = 1.01
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The meshing setup is now completely defined. You can save your simulation file before generating
the mesh :
In the main menu bar, go to « File » -> Save as ... and save you simulation as « 2D_Cylinder.sim »

2.6 Generating the Volume Mesh

In the main menu bar, go to « Mesh » and click on « Generate Volume Mesh »
After a few seconds, the volume mesh is generated. The final number of cells should be 16 450.
The resulting volume mesh is displayed in « Geometric Scene 1 ».

Volume mesh for the whole domain

In the tree, go into « Parts » in « Surface 1 » and select all boundaries in « Region »
We can see the volume mesh at the surfaces of the computation domain.

Volume mesh (refinement in the wake)

2.7 Volume Mesh Diagnostics

We check the mesh quality :
In the main menu bar, go to « Mesh » -> Diagnostics
Verify « Region » is enabled and click « OK »
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The report should be :

---------------------------------------------------
--- Computing statistics in Region: Region
---------------------------------------------------

-> ENTITY COUNT:
   # Cells: 16450
   # Faces: 46873
   # Verts: 30636
-> EXTENTS:

   x: [-1.0000e+00,  1.0000e+00] m
   y: [-1.0000e+00,  1.0000e+00] m
   z: [ 0.0000e+00,  0.0000e+00] m

-> MESH VALIDITY:
   Mesh is topologically valid and has no negative volume cells.

-> FACE VALIDITY STATISTICS: 
Minimum Face Validity: 1.000000e+00
Maximum Face Validity: 1.000000e+00

        Face Validity <  0.50           0    0.000%
0.50 <= Face Validity <  0.60           0    0.000%
0.60 <= Face Validity <  0.70           0    0.000%
0.70 <= Face Validity <  0.80           0    0.000%
0.80 <= Face Validity <  0.90           0    0.000%
0.90 <= Face Validity <  0.95           0    0.000%
0.95 <= Face Validity <  1.00           0    0.000%

1.00 <= Face Validity               16450   100.000%
-> VOLUME CHANGE STATISTICS:

Minimum Volume Change: 1.889554e-01
Maximum Volume Change: 1.000000e+00

         Volume Change <  0e+00           0    0.000%
0e+00 <= Volume Change <  1e-06           0    0.000%
1e-06 <= Volume Change <  1e-05           0    0.000%
1e-05 <= Volume Change <  1e-04           0    0.000%
1e-04 <= Volume Change <  1e-03           0    0.000%
1e-03 <= Volume Change <  1e-02           0    0.000%
1e-02 <= Volume Change <  1e-01           0    0.000%

1e-01 <= Volume Change <= 1e+00       16450   100.000
Mesh Diagnostics Report

First we can notice we have no negative volume cell. Only one negative volume cell will make the
simulation unstable and it will diverge very fast.

All cells for our mesh have a value of 1.0 for the face validity and a minimum of 1.889554e-01 for
the volume change.

However that does not mean the mesh is fine enough to model correctly all physical phenomema
we want to simulate. A mesh convergence study is often necessary.


